关于nodejs和npm版本不匹配的情况

linux系统中安装node和npm不匹配问题的解决

方法一 根据node 修改npm版本号

今天在安装node.js后使用 npm安装 BtleJuice
遇到了如下情况。

记录一下该情况看是否有相同问题的朋友就不用了走弯路

出现该情况说明node.js和npm版本不搭配
直接在终端输入

1
node -v

查看node版本号

1
npm -v

查看npm 的版本号

提供如下网站查看
https://nodejs.org/zh-cn/download/releases/

然后输入查找对应的版本号
例如我的node版本是 10.15.1 对应的npm版本号是6.4.1

我就在终端输入

1
npm install -g npm@6.4.1

然后就成功匹配了。

若要升级到最新的npm

1
npm install -g npm

方法二:根据npm 修改node

直接卸载node 然后在官网上重新下载
如果依旧不行 执行方法一

谢翔 wechat
坚持原创技术分享,您的支持将鼓励我继续创作!
-------------本文结束感谢您的阅读-------------
0%